Bulblub

phpbrewでphp5.3.13とHomebrewでXdebugをインストール

June 07, 2012

phpbrewでphp5.3.13を入れてhomebrewでphp53-xdebugを入れたら以下のように怒られたのでその対処メモ

$ php -i | grep “Extension” Xdebug requires Zend Engine API version 220100525. The Zend Engine API version 220090626 which is installed, is outdated.
PHP Extension => 20090626 Zend Extension => 220090626 Zend Extension Build => API220090626,NTS PHP Extension Build => API20090626,NTS Extension Version => 2.0 ($Id$) Extension Version => $Id$

要するにXdebugが新し過ぎるということで、バージョンをひとつ落としてやった。 Homebrewで管理したいので、Formulaを書いた。 [gist id=2885752 bump=1] Formulaを追加して、インストール

$ brew install php53-xdebug214

おしまい

Tags:

Tomotsugu Kaneko

Written by Tomotsugu Kaneko who lives and works in Japan. Follow me on Twitter