Bulblub

Amazon Linux AMI 2018.03にgsutilをインストールする

December 17, 2018

Amazon Linux AMI 2018.03 での話でググっても出てこなかったのでメモ

gsutil をインストールする | Cloud Storage ドキュメントの手順の通りインストールしようとするとpythonのバージョンが古いぽいエラーが出る

curl https://sdk.cloud.google.com | bash

インストールスクリプト内部ではpython2を使ってるっぽいんだけど、これが2.6.xであることが原因で失敗している模様。以下確認

$ ls -la /usr/bin/python2
lrwxrwxrwx 1 root root 9 12月 11 22:10 /usr/bin/python2 -> python2.6

これを2.7.xへ変えてやる。

$ sudo ln -nfs /usr/bin/python2.7 /usr/bin/python2
$ ls -la /usr/bin/python2
lrwxrwxrwx 1 root root 18 12月 17 17:44 /usr/bin/python2 -> /usr/bin/python2.7
$ python2 --version
Python 2.7.15

で再度インストールスクリプトを実行してインストール完了。

Tags:

Tomotsugu Kaneko

Webのフロントエンドからバックエンド、プロトタイピングからプロダクションまで。定額の開発サービスも。詳しくはAboutページで。